требования к использованию NukeViet 4

Требования к использованию NukeViet 4

Номер 13
Начать сбор комментариев 08/05/2018
Завершить комментарии Бессрочно
Состояние Принято
Дата вступления в силу
Дата окончания
Категория NukeViet Wiki
Область применения NukeViet 4
Тема главная
Комитет по проверке Первый комитет подписантов
Подписант nukeviet

Содержание

Обязательные требования

  • Операционная система: Linux (Ubuntu, Fedore, CentOS ...) или Windows. Должен быть развернут на CentOS 7
  • PHP: PHP 5.6 ⇒ PHP 7.2 1) и следуйте требуемым библиотекам
    • Поддержка объектов данных PHP (PDO)
    • PHP поддерживает opendir
    • PHP поддерживает библиотеку обработки изображений GD
    • PHP поддерживает криптографическую библиотеку Openssl
    • Поддержка PHP-сессии
    • PHP поддерживает загрузку файлов
  • MySQL: MySQL 5.5 или новее

Дополнительные параметры

  • Сервер Apache должен поддерживать mod_rewrite mod.
  • Сервер Nginx настраивает параметры перезаписи.
  • Серверу IIS 7.0 или IIS 7.5 требуется модуль перезаписи
  • Расширенная среда PHP: PHP-библиотеки нуждаются в файлах: file_uploads, session, mbstring, curl, gd2, zlib, soap, php_zip.

Примечания:

  • Вышеуказанные требования не означают, что NukeViet 4 не работает в других системах, важно создать подходящую рабочую среду.

Конфигурация оборудования

Для NukeViet 4 требуется очень низкая аппаратная конфигурация, даже самые дешевые sharehosts теперь могут работать. Полоса пропускания интернета, емкость хоста или жесткий диск полностью зависит от использования устройства. (Программный пакет NukeViet занимает примерно 10 МБ пространства (zip-файл), а при распаковке - 30 МБ.

Примечания:

Посетитель компьютера

NukeViet 4 приводит к стандартным HTML5 и CSS 3, это стандартный формат, который поддерживает большинство браузеров. Таким образом, веб-сайты NukeViet 4 имеют хороший доступ к последним версиям Firefox, Internet Explorer 9, Google Chrome и т. Д. Пользователи, которым необходимо установить только один из этих браузеров, смогут получить к нему доступ. взаимодействовать с NukeViet через Интернет или интранет.


1)
Это требование NukeViet 4.3.01 для других версий требований PHP следующим образом: NukeViet <4.3.01 требует php 5.5 ⇒ 7.1

  Комментарии Читателей

Код   

Материалы в этой же категории "NukeViet Wiki"

Статистика
  • Онлайн10
  • Сегодня63
  • Месяц6,149
  • Всего48,596
Вы не пользовались панелью управления сайтом слишком долго, нажмите здесь, чтобы остаться залогиненными в СУС. Система будет ожидать: 60 Секунд